Entradas etiquetadas: Error

Error 501 Not Implemented en WordPress

Wordpress

Editando una entrada me sorprendió obtener este error

Error 501 Not Implemented

porque no ocurría siempre, solo me ocurría con esa entrada en particular, menos mal que google es nuestro amigo y tras rebuscar un rato debe ser problema de la seguridad del servidor… y parece ser que las soluciones son sencillas.

La más sencilla y NO RECOMENDADA deshabilitar la seguridad del servidor.

Intentar buscar que parte del texto da el error para intentar escribir otra cosa que no de problemas(que fue lo que hice yo)

Y como último recurso aunque muy poco ortodoxo sería escribirlo en otro sitio para hacer una captura de pantalla y ponerlo como imagen en el post, algo que iría contra los cánones del SEO  entre otros.

Si la segunda opción es muy complicada, siempre podemos deshabilitar la seguridad, enviarlo y volver a habilitarla. Lo que ya no sé es si luego tendríamos problemas al visualizarla de forma normal.

Para ello habría que poener en el .htaccess SecRuleInheritance Off pero esto solo funcionaría con el mod_security, el mod_security2 no puede ser deshabilitado desde el .htaccess

fatal error: ‘php.h’ file not found en OSX

Mac, PHP

Como ya he dicho muchas veces me siento un ignorante en este nuevo mundo de apple y cosas que para muchos les será trivial para mi es algo que me cuesta :)

 

Al estar instalando cosas en el servidor me estaban dando un error:

fatal error: ‘php.h’ file not found

Finalmente encontre la solución.
Copiar el directorio php de

/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk/usr/include/php

en

/Applications/MAMP/bin/php/php5.3.20/include/php

Falló al descargar la información del repositorio, Ubuntu 12.04

Ubuntu

De repente mi Ubuntu 12.04 dejó de actualizarse y me salía un icono en la barra superior que decía que la información de actualización está obsoleta y cuando iba al gestor de actualizaciones para comprobar las actualizaciones daba error.

Error repositorios ubuntu

El motivo es debido a unos repositorios que se han quedado obsoletos y hay que eliminar, para ello desde el gestor de actualizaciones, abajo a la izquierda, pulsamos en configuración y en la pestaña Otro Software desmarcamos los repositorios que nos dan problemas (Son los que aparecen al expandir Detalles en el mensaje de error anterior)

Volvemos a darle a comprobar y podremos observar como esta vez no nos lanza ningún error.