Entradas etiquetadas: MAMP

Cambiar versión de PHP en MAMP

Mac, Programación

Ya escribí un artículo sobre esto pero considero que es una manera un poco chapucera de hacerlo. Buscando por la red creo que hay formas mas ortodoxas como por ejemplo

Primero buscamos donde está nuestra versión

which php

En mi caso

/usr/bin/php

Renombramos

sudo mv /usr/bin/php /usr/bin/php.back

creamos el symlink con la versión de php que quereamos por ejemplo 5.4.26

sudo ln -s /Applications/MAMP/bin/php/php5.4.26/bin/php /usr/bin/php

y finalmente comprobamos que tenemos la nueva versión

php -v

 

Y listo

Actualizando MAMP

Mac

Para evitar perder nuestras configuraciones y bases de datos lo que primero haremos será sobreescribir la carpeta MAMP de Aplicaciones.

Ahora  ya podemos bajarnos la nueva versión e instalarla.

Ya solo nos queda copiar los datos que teníamos antes.

 

Sobreescribimos la carpeta htdocs si tuviéramos aquí nuestras webs, en mi caso como los tengo en otros directorios copiare la información de los virtual hosts en /conf/apache/extra/httpd-vhosts.conf

También sobreescribimos la carpeta db para disponer de nuestras bases de datos antiguas.

 

Arrancamos el servidor y ya tenemos nuestras webs otra vez listas.

 

Si por un casual no funciona hay que tener en cuenta que hay que dejar los puertos de Apache y MySQL (Preferencias / Puertos) como los teníais antes.

Seleccionar php 5.3 en MAMP

PHP

Por una extraña razón a pesar que en mi carpeta/Applications/MAMP/bin/php/ tengo varias versiones de php (5.2.17, 5.3.20, 5.4.10) cuando en preferencias voy a cambiar la versión de PHP solo me aparecen 2

 

Seleccionar version php mamp

 

No se si será lo más ortodoxo pero por lo menos funciona.

Renombre la carpeta del php 5.2 para que terminara en _X y reinicié MAMP y funcionó. Ya me dejó seleccionar la 5.3